Miro

Miro Internet TV Blog

New Testing Builds

November 18th, 2006 by Nicholas Reville

We have new testing versions of Democracy Player 0.9.2. There are a few more things we’re working on, but this is almost final, so please let us know if you spot any problems. You should notice significantly reduced memory use (we still have more improvements to make) and improved speed and responsiveness.

Testing Versions

If you find a bug, please let us know. Thanks!

Update I should have warned that you should only try these testing builds if you are willing to possibly have some problems. These are still pre-release and have some serious bugs.

20 Responses to “New Testing Builds”

  1. Tim says:

    The “let us know” link just goes to the nightlies page.

    I got this upon startup the first time, but it still appears to work ok afterwards:

    DTV: Starting up Democracy Player
    DTV: Version: 0.9.2-20061117
    DTV: Revision: https://svn.participatoryculture.org/svn/dtv/trunk/tv – 3721
    DTV: Loading preferences…
    DTV: Restoring database…
    Upgrading database…
    upgrading database to version 25
    upgrading database to version 26
    upgrading database to version 27
    upgrading database to version 28
    Database load slow: 68.254
    DTV: Recomputing filters…
    DTV: Launching Download Daemon
    DTV: Spawning auto downloader…
    DTV: Displaying main frame…
    DTV: Increasing file descriptor count limit in Downloader.
    Traceback (most recent call last):
    File “/Applications/Democracy.app/Contents/Resources/__boot__.py”, line 31, in ?
    _run(‘Democracy.py’)
    File “/Applications/Democracy.app/Contents/Resources/__boot__.py”, line 28, in _run
    execfile(path, globals(), globals())
    File “/Applications/Democracy.app/Contents/Resources/Democracy.py”, line 99, in ?
    launchDownloaderDaemon()
    File “/Applications/Democracy.app/Contents/Resources/Democracy.py”, line 66, in launchDownloaderDaemon
    resource.setrlimit(resource.RLIMIT_NOFILE, (-1,-1))
    AttributeError: ‘module’ object has no attribute ‘setrlimit’
    2006-11-19 17:26:34.067 Downloader[329] Democracy Error
    2006-11-19 17:26:34.068 Downloader[329] An unexpected error has occurred during execution of the main script

    AttributeError: ‘module’ object has no attribute ‘setrlimit’

  2. Nicholas Reville says:

    Thanks Tim. Did your list of channels and videos get erased or did it remember your stuff?

  3. Nicholas Reville says:

    Fixed that link too, thanks.

  4. Mike says:

    Ahhhhhhhhhhh! :( It erased all my feeds! Oh my… shit… wow, I can’t get them back, can I? That was a lot of feeds. I’m sad now.

  5. Nicholas Reville says:

    Dang… sorry about that. What version were you upgrading from?

  6. Verdi says:

    This version seemed to fix the display bugs of the last version but I couldn’t get any files to download. So I tried to install the last public release and it tells me my database is too new.

  7. Tim says:

    Yeah, I can no longer download video either. At least it didn’t wipe my feed list, I should probably back that up… (any ideas how to do this easily?)

  8. m--s says:

    After upgrading from the previous testing build all I can get is a message window with the following message:

    XML Parsing Error: error in processing external entity reference
    Location: chrome://dtv/content/main.xul
    Line Number 5, Column 55:
    ——————————————————^

    All the previous upgrades (including the one few days ago from 0.9.1 to nighly) went flawless, while that upgrade rendered DP unusable (it just quits after displaying this window)

    Windows XP SP2 Polish version here.

  9. m--s says:

    some of my previous message has disappeared, probably because it looked like html tags – anyway, the problem reappears after creating the fresh profile and substituting the “database” folder in a profile with a one from the previous profile. These files are not human-readable, so I cannot go any further in providing useful information.

  10. Nicholas Reville says:

    Hi Everyone, I should have warned that testing builds are dangerous beasts. Sorry about these problems, I think we’ll be able to get a new version out in the next day or two that should be able to get you going again. The only things that aren’t recoverable from are when the database gets lost, which is most likely to happen if you upgrade from an old version.

  11. joey says:

    geez, doesn’t even open for me (winxp). It just blinks and is gone. Leaves the process “democracy downloader” open too.

    I can’t even run a stable version and I want to so bad! My computer just totally craps out, RAM maxed out and I can’t do anything until I close the app. I sincerely hope this next version makes it usable for me. I really want it to be a main utility for my computer.

  12. walden says:

    I got the same XML Parsing Error on attempting to run 0.9.2-rc0 after installing. Installing went okay.

    Version 0.9.1 installed and ran perfectly. However it had two problems: the huge memory leak mentioned in the forums and also the bug with full screen where the top and bottom bars don’t disappear after leaving the mouse cursor alone.

    Specs for my system: Windows XP SP2 on a Pentium 4 system.

  13. bsboard says:

    I get an XML parsing error (different from others’)

    XML Parsing Error: undefined entity
    Location: chrome://dtv/content/main.xul
    Line Number 8, Column 1:

    I was messing with the xml in the file, and it appears to hang up on the ‘&’ signs. I removed all of them, and then the program started up fine. (however then the menu titles are incorrect, e.g. ‘main.menu.file’)

  14. Nicholas Reville says:

    Everyone, thanks so much for the bug reports.

    bsboard- thanks especially for this tip. I wonder if it will solve all the parsing problems… it’s been passed on to the developers:

    https://develop.participatoryculture.org/democracy/ticket/4931#comment:1

    If we can fix this in the morning, we may have an RC1 by the afternoon. Stay tuned…

  15. Chris Lahey says:

    m–s:

    Which nightly did you have that worked just fine? I see no changes from the one on Friday that could cause this, but will keep looking. Perhaps it’s a difference in how the build was made.

  16. m--s says:

    Chris Lahey: it was an upgrade from 0.9.2-20061114 to 0.9.2-20061117 with a full profile kept (a lot of feeds inside). I’ve also submitted a ticket (4908) about what happens with starting a fresh profile in 0.9.2-20061117 – similar problems, but this time applying to the “preferences” dialog.

    In this ticket I also described a change I did with the file “prefs.js” after upgrading from 0.9.1 to 0.9.2-20061114 to prevent the preferences dialog from failing to appear (sorry for my English :) ). Anyway, later I tried to revert that change, reverted back to 0.9.2-20061114 (I restored a full backup of the profile), and then upgrading without applying that change. It failed, again, so I gave up on the profile :( and tried to start with a fresh one. That way I was at least able to start DP, but the preferences dialog is inaccessible for me, so it is unusable (0.9.2-20061117).

  17. m--s says:

    Ok, maybe I wasn’t clear enough about my “upgrade path”, so here it is…

    a) 0.9.1 -> 0.9.2-20061114: problem with the “preferences” dialog, solved with a simple change in prefs.js (mentioned in ticket 4908),

    b) 0.9.2-20061114 -> 0.9.2-20061117: DP starts, displays the message, then quits immediately – this has been described in my first post here,

    c) reverted to 0.9.2.20061114, also restored my profile from backup, this time not changing the prefs.js, trying to upgrade again to 0.9.2-20061117: DP still fails, like in b),

    d) uninstalled DP, deleted the profile and settings, done the fresh installation of 0.9.2-20061117: detailed information about the results are described in ticket 4908,

    e) also tried copying just the database files to the fresh profile created in d), this caused the same behavior as in b). This is also mentioned in my second post here.

    Sorry for the mess, I hope this is helpful ;)

    The problem here is probably related to a localized (Polish) version of Windows XP SP2. IMHO there should also be an UI option to change the default language (I always prefer the English version of any application, because i am more used to “internet English” than to “internet Polish”, the latter sounding funny at best :) ).

  18. Chris Lahey says:

    I was able to reproduce this by running under Polish and have fixed it. It should be fixed for the release. Thanks much.

  19. m--s says:

    Chris Lahey: great news – thanks!

    Please also keep in mind, that rc0 has (or maybe had, after your fixes ;) ) even more XML-related problems; I’ve added the full description as a comment to a ticket 4908.

  20. Nicholas Reville says:

    RC1 for windows is now posted. I’m curious if that solves the problems you all seen. Let us know if anything is still broken!

Looking for something?