Miro

Miro Internet TV Blog

Democracy 0.9.2 for Debian and Ubuntu Available

December 1st, 2006 by Nicholas Reville

If you haven’t noticed already, the Debian and Ubuntu versions of Democracy Player are available now: get them.

13 Responses to “Democracy 0.9.2 for Debian and Ubuntu Available”

  1. aidanr says:

    :( unfortunatly this version doesn’t work very well, i tried installing the deb and from source and both times the player
    (a) got rid off all my channels and replaced them with the defaults and (b) crashed whenever i tried to play anything

    another thing i don’t like about this version is the search bar at the bottom left, there doesn’t seem to be anyway of hiding it, and it just seems unnecessary when theres already a search function built in

    it would be nice if there was a link to older versions of the player on the download page, luckily i managed to find a deb for 0.9.1 on this page http://home.eng.iastate.edu/~superm1/dists/edgy/other/

  2. john doe says:

    Debian testing (etch) repository also has 0.9.1. I hope it will eventually upgrade to 0.9.2 (love them system-wide automatic upgrades ( :D Grin )!)

  3. john doe says:

    The 0.9.1 packages (for now) in debian testing (etch) can be downloaded from:

    http://packages.debian.org/testing/net/democracyplayer
    http://packages.debian.org/testing/net/democracyplayer-data

  4. Igor says:

    Still not working sound in flash video in Edgy

  5. WalterBE says:

    I use it now and I like it. But what I mis control of the program by the keyboard. Like F for fullsreen, space for pauze, arrow left and right to skip a video

  6. JP says:

    The Ubuntu package says it is for Dapper — is this package supposed to work for Edgy too?

  7. tomwsmf says:

    Installing on my updated dist-upgraded Dapper install and I get dependency faux pas’ all over the place. Tried it on the laptop and got the same deal. IS this just me having a senior moment or is it happening to other Dapper young turks?

    -tomhiggins

  8. tomwsmf says:

    Here are the errors Im getting

    Selecting previously deselected package democracyplayer.
    (Reading database … 235762 files and directories currently installed.)
    Unpacking democracyplayer (from democracyplayer_0.9.2.1-1ubuntupcf_i386.deb) …
    dpkg: dependency problems prevent configuration of democracyplayer:
    democracyplayer depends on libatk1.0-0 (>= 1.12.1); however:
    Version of libatk1.0-0 on system is 1.11.4-0ubuntu1.
    democracyplayer depends on libc6 (>= 2.4-1); however:
    Version of libc6 on system is 2.3.6-0ubuntu20.
    democracyplayer depends on libcairo2 (>= 1.2.4); however:
    Version of libcairo2 on system is 1.0.4-0ubuntu1.
    democracyplayer depends on libgcc1 (>= 1:4.1.1-12); however:
    Version of libgcc1 on system is 1:4.0.3-1ubuntu5.
    democracyplayer depends on libglib2.0-0 (>= 2.12.0); however:
    Version of libglib2.0-0 on system is 2.10.3-0ubuntu1.
    democracyplayer depends on libgtk2.0-0 (>= 2.10.3); however:
    Version of libgtk2.0-0 on system is 2.8.20-0ubuntu1.
    democracyplayer depends on libpango1.0-0 (>= 1.14.5); however:
    Version of libpango1.0-0 on system is 1.12.3-0ubuntu3.
    democracyplayer depends on libstdc++6 (>= 4.1.1-12); however:
    Version of libstdc++6 on system is 4.0.3-1ubuntu5.
    democracyplayer depends on libxine1 (>= 1.1.2-5); however:
    Package libxine1 is not installed.
    democracyplayer depends on python-support (>= 0.3.4); however:
    Package python-support is not installed.
    democracyplayer depends on python-gnome2-extras (>= 2.14.0-2); however:
    Version of python-gnome2-extras on system is 2.14.0-0ubuntu3.
    dpkg: error processing democracyplayer (–install):
    dependency problems – leaving unconfigured
    Errors were encountered while processing:
    democracyplayer

  9. GerwinDeHaan says:

    Yep Tomwsmf, same upgraded dapper config here, same errors!

  10. a random netsurfer says:

    I’m having problems with the new 0.9.2 in ubuntu edgy (many movies don’t play). Found a place to get the 0.9.1 deb’s:
    http://ftp.osuosl.org/pub/pculture.org/democracy/linux/ubuntu/

  11. Niels Walta says:

    Same problem as mentioned above, running Edgy and Democracy Player now refuses to play several videos that used to work in the previous version.

  12. Niels Walta says:

    Me again. The work-around posted in http://forum.getmiro.com/viewtopic.php?id=882 seems to do the trick for me for now. I just hope the implementation gets fixed for the next release.

  13. Martin Barr-David says:

    Democracy Player doesn’t work in Kubuntu Feisty following error
    martbd@martbd-desktop:~$ sudo dpkg -i democracyplayer_0.9.2.1-1ubuntupcf_i386.deb
    (Reading database … 130407 files and directories currently installed.)
    Preparing to replace democracyplayer 0.9.2.1-1ubuntupcf (using democracyplayer_0.9.2.1-1ubuntupcf_i386.deb) …
    Unpacking replacement democracyplayer …
    dpkg: dependency problems prevent configuration of democracyplayer:
    democracyplayer depends on python (

Looking for something?