Miro

Miro Internet TV Blog

Linux versions of 0.9.6 available, including Feisty

June 5th, 2007 by Nicholas Reville

Most of the gnu/linux versions of 0.9.6 have been posted at the downloads page: Go get em. This includes support for Ubuntu Feisty.

Update: there were some issues, but it should be fixed now.

20 Responses to “Linux versions of 0.9.6 available, including Feisty”

  1. Paul Ivanov says:

    The Ubuntu Feisty url on the downloads page in incorrect, the end reads fiesty/ instead of feisty/ – here’s what it should be:

    deb http://ftp.osuosl.org/pub/pculture.org/democracy/linux/repositories/ubuntu feisty/

  2. Roel says:

    Thanks for the Feisty repository, and all the work done on 0.9.6!

    (I noticed the fiesty error, so no worries. ;) Downloading…)

  3. haggai_e says:

    Will there be an amd64 package, like there was for edgy?

  4. Still crashes for me, The version in the ubuntu repos works however

    earobinson@NaN:~$ democracyplayer
    /usr/bin/democracyplayer:87: DeprecationWarning: The dbus_bindings module is deprecated and will go away soon.

    dbus-python 0.80 provides only a partial emulation of the old
    dbus_bindings, which was never meant to be public API.

    Most uses of dbus_bindings are applications catching the exception
    dbus.dbus_bindings.DBusException. You should use dbus.DBusException
    instead (this is compatible with all dbus-python versions since 0.40.2).

    If you need additional public API, please contact the maintainers via
    .

    import dbus_bindings
    /var/lib/python-support/python2.5/dbus_bindings.py:5: DeprecationWarning: The dbus_bindings module is deprecated and will go away soon.

    dbus-python 0.80 provides only a partial emulation of the old
    dbus_bindings, which was never meant to be public API.

    Most uses of dbus_bindings are applications catching the exception
    dbus.dbus_bindings.DBusException. You should use dbus.DBusException
    instead (this is compatible with all dbus-python versions since 0.40.2).

    If you need additional public API, please contact the maintainers via
    .

    from dbus.dbus_bindings import *
    INFO Starting up Democracy Player
    INFO Version: 0.9.6
    INFO Revision: unknown
    INFO Loading preferences…
    INFO Starting event loop thread
    INFO Restoring database…
    INFO Connecting to /home/earobinson/.democracy/sqlitedb
    TIMING Database load slow: 0.463
    INFO Recomputing filters…
    INFO Spawning auto downloader…
    INFO Displaying main frame…
    WARNING Menu item action “CheckVersion” not implemented
    WARNING Menu item action “FastForward” not implemented
    WARNING Menu item action “Rewind” not implemented
    WARNING Menu item action “UpVolume” not implemented
    WARNING Menu item action “DownVolume” not implemented
    WARNING Volume changed before videoDisplay created
    WARNING Display updated before video display was created
    INFO Creating video display…
    INFO *** Launching Downloader Daemon ****
    alsa
    oss
    pulseaudio
    file
    none
    INFO loaded renderer ‘xinerenderer’
    INFO Setting VolumeLevel to 1.0
    TIMING gtkAsyncMethod: took too long: 1.483
    Segmentation fault (core dumped)

  5. Joan says:

    I have the same output as Edward on Feisty. The SVN version works pretty well.

  6. Nicholas Reville says:

    Sorry about all these problems— we’re working on it!

  7. AC says:

    Is there a bugreport? Perhaps with an RSS, so i can be notified on updates to it?

  8. Ben says:

    Hi folks, we just updated the feisty packages. The segfault should be fixed now.

    Ben

  9. AC says:

    I was pretty impatient, sorry. It works now. Thanks a million. Finally. Been waiting for this for quite a while. Feisty has been out for some time now.

  10. Greg says:

    Hi,
    Installed on Feisty great, but, how do enable proxy support?
    I cannot find an option anywhere and when I export the proxy that does not work either!

  11. [...] I wrote about Democracy a month ago, back then the biggest comment that I got was that Democracy wouldent work for them. Democracy just released version 0.9.6 today and in the release post they claimed to have fixed support for feisty. Now I have been running the stock version that comes in the Ubuntu repository’s and I must say it is a product that once you use it you will never go back. I love coming home and having all of my vlogs downloaded for me ready to watch, I just wish I could find more Ubuntu vlogs, if anyone can find some let please post a link in the comments. I’m quite adventurous when it comes to Ubuntu and I will install anything weather or not I think it will break my system. So I backed up my ~/.democracy folder added the democracy repository, they have a great tutorial by the way, to my sources.list and upgraded. [...]

  12. Pla says:

    Could you release a package for amd64 as well?

  13. [...] I wrote about Democracy a month ago, back then the biggest comment that I got was that Democracy wouldent work for them. Democracy just released version 0.9.6 today and in the release post they claimed to have fixed support for feisty. Now I have been running the stock version that comes in the Ubuntu repository’s and I must say it is a product that once you use it you will never go back. I love coming home and having all of my vlogs downloaded for me ready to watch, I just wish I could find more Ubuntu vlogs, if anyone can find some let please post a link in the comments. I’m quite adventurous when it comes to Ubuntu and I will install anything weather or not I think it will break my system. So I backed up my ~/.democracy folder added the democracy repository, they have a great tutorial by the way, to my sources.list and upgraded. [...]

  14. Anonymous says:

    When is the version for Fedora Core 6 coming out?

  15. Nicholas Reville says:

    Fedora 6 is up, I believe, is that not working?

  16. Sam says:

    Awesome. It used to crash after a video finished playing forcing the use of a separate media player – it’s good to see it fixed.

    Looking forward to the release of Miro.

  17. M. Miyojim says:

    I have just downloaded DemocracyPlayer 0.9.6 and thank you for making such a fine application available on my Ubuntu 7.04 desktop.

    However, there are a few mp4 files that I downloaded from the Archive of Classic Movies which cause my PC to freeze completely, so I have to do a hardware restart. I thought it was only those market for ipod download but I downloaded one which was not marked so, yet it also froze my PC entirely. I understand that there are formats that DemocracyPlayer cannot understand, but it should have a safety feature to just reject it and not crash the operating system. I thought GNU/Linux was safe from application crashes bringing the OS down, but I see that it is not so.
    Could you explain the problem? Thank you.

  18. PuZZleDucK says:

    Please please please release an amd64 package…
    The automatic update of democracy-data has disabled democracy and now I can’t get Miro to install because of dependency issues. So now I can’t run either.

Looking for something?